View unanswered posts | View active topics It is currently Thu Aug 17, 2017 8:40 am





Reply to topic  [ 10 posts ] 
 PCS1 Flo oil filter 
Author Message

Joined: Sun Oct 04, 2015 6:49 pm
Posts: 1
Perhaps this has been covered elsewhere, but important enough to be repeated for those of us wanting to use reusable filters.

So I had a Flo Billet Oil Filter PCS1 come apart (end caps separated from filter element). Called around trying to figure out who to scream at and ended up talking to K&P Engineering who actually makes the REAL one... The FLO is a china knock off and apparently only marginally better than using a dish rag.

I spoke to Dave at K&P (720)238-1181 who went into great detail about the misleading marketing of dealers and distributors that sell the FLO as the same quality as the K&P, which it is NOT... the K&P is certified for use in aircraft and much better quality, especially in durability and filter function.

If it is the real deal, it will be engraved K&P and the part number for the ZX14R is S1, NOT PCS1. Apparently the PC stands for piece of crap.

When the FLO grenades it will throw a bunch of nasty hard glue bits everywhere and probably require a tear down or at least a new pickup. It didn't cause my rebuild, but I saw a bunch of that orange crap everywhere in the cases afterwards, in fact two oil changes after the FLO was replaced is when I did the rebuild (thought I was using too aggressive of a cleaner or too much heat hot lapping it).

I originally had a K&P S1 on a bike I sold and loved it so asked the dealer to get me a new one, neither of us knew it was the knock off and he sourced it from PU.


Mon Oct 05, 2015 11:41 am
Profile
Moderator
User avatar

Joined: Sat Jan 19, 2013 2:36 pm
Posts: 2996
Location: Dallas Texas
I use oem.

wee


Mon Oct 05, 2015 11:46 am
Profile
User avatar

Joined: Fri Apr 12, 2013 12:05 pm
Posts: 143
Location: Liverpool, U.K.
Very informative first post Eric.
I'm sure you have no connection with K&P (720)238-1181
and therefore no vested interest in panning the competition. :bigthumb:

I use OEM too! :D


Mon Oct 05, 2015 1:02 pm
Profile
User avatar

Joined: Sun Jan 20, 2013 1:47 am
Posts: 583
Location: Philadelphia, Pennsylvania
Wheelie wrote:
I use oem.

wee


Me too! :thumbs:
Image

_________________
check me out @ Ninja ZX-14 MOTOVLOG


Mon Oct 05, 2015 1:55 pm
Profile WWW
Online

Joined: Mon Mar 10, 2014 5:56 pm
Posts: 72
China crap? well unless you guys who use kawasaki OEM have some old stock filters,you need to look at the new kawasaki boxes , MADE IN CHINA! ive been using the flo filter for almost 3 yrs on my turbo 14 and my 30t without a problem .


Tue Oct 06, 2015 7:44 am
Profile
Moderator
User avatar

Joined: Sat Jan 19, 2013 2:36 pm
Posts: 2996
Location: Dallas Texas
kawpower wrote:
China crap? well unless you guys who use kawasaki OEM have some old stock filters,you need to look at the new kawasaki boxes , MADE IN CHINA! ive been using the flo filter for almost 3 yrs on my turbo 14 and my 30t without a problem .

I'm sure the oem Kawasaki filter is up to Kaw specs even if it says China.

wee


Tue Oct 06, 2015 10:12 am
Profile
User avatar

Joined: Sun Jan 20, 2013 1:47 am
Posts: 583
Location: Philadelphia, Pennsylvania
kawpower wrote:
China crap? well unless you guys who use kawasaki OEM have some old stock filters,you need to look at the new kawasaki boxes , MADE IN CHINA! ive been using the flo filter for almost 3 yrs on my turbo 14 and my 30t without a problem .


Sonny, if products made in China are good for Donald Trump, they should be ok for us mere mortals. :thumbs:
Image

_________________
check me out @ Ninja ZX-14 MOTOVLOG


Tue Oct 06, 2015 5:55 pm
Profile WWW
User avatar

Joined: Sat Oct 19, 2013 10:37 am
Posts: 385
Location: central Illinois
I had the FLO PCS1, mistake number 1 that I made with it was torquing it to the oem 13ft lbs. Came loose at top of 1st gear.... They need to be 20-25 ft lbs. I have since sold the filter and now only use NAPA GOLD WIX filters or oem kawasaki. Andy built my engine, and recommended I throw the billet reusable away immediately and use the wix or oem. Needless to say, I did exactly what he said.


Sun Nov 22, 2015 2:03 pm
Profile

Joined: Wed Oct 08, 2014 5:22 pm
Posts: 22
Had a FLO come apart and the glue took out my mains on my 06 zx14, installed a 2013 engine now and only run stock oil filters.


Tue Jan 12, 2016 12:25 pm
Profile
User avatar

Joined: Wed Apr 02, 2014 3:59 pm
Posts: 776
Location: Brisbane, Australia
Given the K&P is around $150 and the OEM is around $8 it's going to take some time before you some kind of financial worth. I would rather just throw away the OEM and go again knowing the filter is up to spec and not bother with any messy cleaning.
But I guess to each their own.


Tue Jan 12, 2016 5:09 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
[ Advertise on ZX1441R.com ]

Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.